Home > EtherChannel Tutorial

EtherChannel Tutorial

January 17th, 2014 Go to comments

EtherChannel Configuration

To assign and configure an EtherChannel interface to an EtherChannel group, use the channel-group command in interface mode: channel-group number mode { active | on | {auto [non-silent]} | {desirable [non-silent]} | passive}
For example we will create channel-group number 1:

Switch(config-if)#channel-group 1 mode ?
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected

If a port-channel interface has not been created before using this command, it will be created automatically and you will see this line: “Creating a port-channel interface Port-channel 1”. In this example, we will create an EtherChannel via LACP between SwA & SwB with the topology shown below: EtherChannel_Switch_configuration.jpg

SwA Configuration SwB Configuration
//Assign EtherChannel group 1 to fa0/0 and fa0/1 and set Active mode on them
SwA(config)#interface range fa0/0 – 1
SwA(config-if-range)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1
//Next configure the representing port-channel interface as trunk
SwA(config)#interface port-channel 1
SwA(config-if)#switchport trunk encapsulation dot1q
SwA(config-if)#switchport mode trunk
//Assign EtherChannel group 2 to fa0/5 and fa0/6 and set Passive mode on them
SwB(config)#interface range fa0/5 – 6
SwB(config-if-range)#channel-group 2 mode passive
Creating a port-channel interface Port-channel 2
//Next configure the representing port-channel interface as trunk
SwB(config)#interface port-channel 2
SwB(config-if)#switchport trunk encapsulation dot1q
SwB(config-if)#switchport mode trunk

That is all the configuration for the EtherChannel to work well on both switches. We can verify with the “show etherchannel <port-channel number> port-channel” or “show etherchannel summary” command.

SwA# show etherchannel 1 port-channel  
     Port-channels in the group:   
     ----------------------------
 Port-channel: Po1
 Age of the Port -channel   = 0d:00h:02m:37s 
 Logical slot/port   = 2/1          Number of ports = 2 
 GC                  = 0x00010001      HotStandBy port = null  
 Port state          = Port-channel Ag -Inuse  
 Protocol            =   LACP
 Port security       = Disabled  
  
 Ports in the Port-channel:  
  
 Index   Load   Port     EC state        No of bits  
 ------+------+------+------------------ +----------- 
   0     00     Fa0/0    Active                  0  
   0     00     Fa0/1    Active                  0  
  
 Time since last port bundled:    0d:00h:02m:27s    Fa0/1

The “show etherchannel number port-channel” command can be used to display information about a specific port channel (in this case port-channel 1). From the command above we can see Port-channel 1 consists of Fa0/0 & Fa0/1 and they are in Active state.

 SwA# show etherchannel summary
Flags:  D  - down        P - bundled in port-channel 
          I - stand -alone s  - suspended 
          H - Hot -standby (LACP only) 
          R - Layer3      S - Layer2 
          U - in use      f - failed to allocate aggregator 
  
          M - not in use, minimum links not met  
          u - unsuitable for bundling  
          w - waiting to be aggregated 
          d - default port 
  
 Number of channel-groups in use: 1 
 Number of aggregators:           1 
  
 Group  Port-channel  Protocol    Ports 
 ------+------------- +-----------+-----------------------------------------------  
 1      Po1(SU)         LACP      Fa0/0(P)   Fa0/1(P) 

The “show etherchannel summary” can be used to simply display one line of information per port-channel. In this case we learn from the last line that Group 1 uses LACP. This is a Layer 2 EtherChannel (symbolized by “SU”, in which “S” means “Layer2” & “U” means this port-channel is up.

EtherChannel Load-Balancing

EtherChannel load-balances traffic among port members of the same channel. Load balancing between member interface is based on:
+ Source MAC address
+ Destination MAC address
+ Source IP address
+ Destination IP address
+ Combination of Source and Destination MAC address
+ Combination of Source and Destination IP address

Note: Some old switch/router flatforms do not support all the load-balancing methods above. To configure load-distribution method, use the command port-channel load-balance under global configuration mode. For example to load-balance based on destination MAC use the command:

Router(config)#port-channel load-balance dst-mac

How the router/switch load-balances traffic among member interface is out of the scope of this article. For more information about EtherChannel load-balancing please visit http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094714.shtml#topic1.

Comments (41) Comments
Comment pages
1 2 2039
  1. avi
    December 10th, 2015

    thank you very much for this helpful tutorial… highly recommended!!

  2. maddy
    January 4th, 2016

    Wonderful explanation..many thanks for the post!!

  3. ghost
    January 7th, 2016

    Since PAgP is Cisco proprietary, don’t you have to use the command – channel-protocol lacp- under the interface before the command -channel-group 1-?

  4. Anonymous
    January 13th, 2016

    Thanks for the info! Although i noticed that the channel-group numbers have to be the same on both devices for it to work properly.

  5. siveeeeeeee
    February 3rd, 2016

    why looping don t present in etherchennal

  6. CHinedu
    February 4th, 2016

    God Bless every body on the site… I appreciate the tutorials i have been studying so far…. This is a big family… Thanks 9tut… Thanks all

    . ..Still studying

  7. Ccna
    February 7th, 2016

    The etherchannel numbers don’t have to be the same

  8. kgisl
    February 8th, 2016

    quite useful…

  9. Arvind
    February 28th, 2016

    Thanks

  10. Anonymous
    March 2nd, 2016

    thank you for this site management but how many maximum etherchannels capable to configure in cisco switch?

  11. JITJASWANT
    March 7th, 2016

    Really its very very help full to get knowledge ….

  12. javos
    April 2nd, 2016

    Helpful thanks

  13. Anonymous
    April 20th, 2016

    i’m so glad to read it sir…Thank’s

  14. Anonymous
    April 25th, 2016

    very Nice!! Thanks :)

  15. diallo
    May 21st, 2016

    tthanks it’s helpful

  16. Anonymous
    May 22nd, 2016

    @9tut team, Your work is highly appreciated.

  17. Omar Baloch
    May 22nd, 2016

    @9tut team, Your work is highly appreciated.

  18. dev
    June 11th, 2016

    It’s very useful for freshers.

  19. Vinnu
    June 18th, 2016

    Superbly presented. Highly appreciate your efforts.
    Thanks a ton :-)

  20. Ahmad
    June 21st, 2016

    asked permission to copy your article

  21. Ahmad
    June 21st, 2016

    tanks

  22. Mr Sho
    July 5th, 2016

    His ghost I think once you type in the mode it determines which of the 2 is being configured. If you type in “active” for instance, you can only have = LACP and if “desirable” then PAgP. Does that make sense?

  23. Tiyan Malaki
    July 15th, 2016

    Hiii.. Can someone send me the lastest dumps please. here’s my email {email not allowed}. Thank you so much!

  24. Anonymous
    August 3rd, 2016

    Awesome information Thanks a lot

  25. Raghuveer
    August 22nd, 2016

    Thank you so much…for clear the issue

  26. Aaryan
    August 30th, 2016

    Nice

  27. Elliot48
    November 1st, 2016

    9tut..doing a great job! Thanks!

  28. ipachauri
    November 3rd, 2016

    good one

  29. abdirahman badri
    December 13th, 2016

    EtherChannel is best thanks allot 9tut

  30. Anonymous
    February 7th, 2017

    54r45

  31. Meryem
    March 17th, 2017

    Thank you so much for all the toturials. I really find them very helpful.

  32. nick2root
    March 22nd, 2017

    thanks for 9tut. awesome information

  33. Sals
    April 17th, 2017

    Very helpful for us. Thanks .

  34. Wendie Henrichs
    April 18th, 2017

    That is the awesome wonderful search system in the world

    http://google.com

  35. Network
    May 19th, 2017

    completely awesome …. thank you for great support to everyone .

  36. tej
    June 7th, 2017

    thank you so much for all this information..its really awesome and helpful to all..nice1

  37. mahede
    June 10th, 2017

    hi all
    can you tell me if i configure LACP both device Active is work?
    SW1 is LACP is active mode and SW2 also Active mode the can negotiate,
    can you tell me if i configure PAgP both device Auto is work?
    SW1 is PAgP is Desirable mode and SW2 also Desirable mode the can negotiate,

  38. vv12
    July 10th, 2017

    someone elese check this problem

    Explanation in dump v27 by genius(can’t paste links here)
    What are two requirements for an HSRP group? (Choose two.)
    A. exactly one active router
    B. one or more standby routers
    C. one or more backup virtual routers
    D. exactly one standby active router
    E. exactly one backup virtual router
    Correct Answer: AD

    i think AB .. :P

  39. vv12
    July 10th, 2017

    Hi guy i’m passed
    ccna 9xx/1000 today

    properly valid v27 and tut guys

    thank you for 9tut

  40. x7xafc
    July 10th, 2017

    @vv12 congratz vv12! what sims did you get?

  41. Anonymous
    October 14th, 2017

    i type “show etherchannel “channel number” port-channel
    but it’s shown “invalid input”
    after that i try to type “show etherchannel port-channel” then it’s shown the result like u’r describe in the tut.

Comment pages
1 2 2039
Add a Comment