Home > CCNA EIGRP Lab

CCNA EIGRP Lab

January 25th, 2014 Go to comments

Question

Your company has just added R3 router to the existing network. But currently no routing updates are being exchanged between R3 and the network. All other connectivity, including Internet access are working properly.

The task is to identify the fault(s) and correct the router configuration to provide full connectivity between the routers.

All passwords on all routers are set to cisco.

IP addresses are listed in the chart below.

ccna_eigrp_sim

R1
Fa0/0: 192.168.77.33
S1/0: 198.0.18.6
S0/1: 192.168.60.25
S0/0: 192.168.36.13
R2
Fa0/0: 192.168.60.97
Fa0/1: 192.168.60.113
S0/0: 192.168.36.14
R3
Fa0/0: 192.168.77.34
Fa0/1: 192.168.60.65
Fa1/0: 192.168.60.81
R4
Fa0/0: 192.168.60.129
Fa0/1: 192.168.60.145
S0/1: 192.168.60.26

Answer and explanation

(Note: If you are not sure how EIGRP works, please read my EIGRP tutorial: http://www.9tut.com/eigrp-routing-protocol-tutorial. Note: You can download this sim to practice here: http://www.9tut.com/download/9tut.com_CCNA_EIGRP_sim_question.zip)

We should check the configuration of the new added router first because it does not function properly while others work well. From the command line interface of R3 router, enter the show running-config command

ccna_eigrp_sim_show_run

From the output above, we know that this router was wrongly configured with an autonomous number (AS) of 22. When the AS numbers among routers are mismatched, no adjacency is formed.

(You should check the AS numbers on other routers for sure)

To solve this problem, we simply re-configure router R3 with the following commands:

R3>enable (you have to enter Secret@9tut as its password here)

R3#configure terminal

R3(config)#no router eigrp 22

R3(config)#router eigrp 212

R3(config-router)#network 192.168.60.0

R3(config-router)#network 192.168.77.0

R3(config-router)#no auto-summary

R3(config-router)#end

R3#copy running-config startup-config

Check R1 router with the show running-config command:

ccna_eigrp_sim_show_run_2

Notice that it is missing a definition to the network R3. Therefore we have to add it so that it can recognize R3 router

R1>enable (you have to enter cisco as its password here)

R1#configure terminal

R1(config)#router eigrp 212

R1(config-router)#network 192.168.77.0

R1(config-router)#end

R1#copy running-config startup-config

Now the whole network will work well. You should check again with ping command from router R3 to other routers!

Modifications:

Maybe in this EIGRP Sim you will see the “passive-interface …” command somewhere in R1 configuration. If the link between R1 to R2; or R1 to R3; or R1 to R4) routers has the “passive interface” then we have to remove it with the “no passive-interface …” command because it prevents EIGRP update from being sent on that interface. But if the “passive interface” is applied to the link between R1 and ISP router like this:

R1:

!
router eigrp 212
passive-interface s1/0
!

then we just leave it. Don’t use the “no passive-interface s1/0” on R1 because the link between R1 & ISP doesn’t need EIGRP to run on it. A static route from R1 to ISP & “ip default-network” command in R1 are correct so that all the routers (R1, R2, R3, R4) can access the Internet.

(Note: The “ip default-network” command in R1 will advertise the static route of R1 (to go to the Internet) to other routers (R2,R3,R4) so that they can access the Internet too). In the exam you will see these lines in R1 configuration:

!
ip default-network 198.0.18.0
ip route 0.0.0.0 0.0.0.0 198.0.18.5
!

If you want to learn more about “ip default-network” command please read: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml

I read recent comments and realized that you will see the “passive-interface” in the link between R1 & ISP router so just leave it.

Note: Also some readers confuse about if we should use the wildcard masks on the “network” statements under EIGRP process or not. For example should we use:

router eigrp 212
network 192.168.77.0 0.0.0.3

The answer is: we can use wildcard masks or not, it does not matter. Not having a wildcard mask does not make the routes conflicting. The “network …” command in EIGRP (and OSPF, RIP) does not means “advertise this network” but means “If I has interface(s) belongs to this network please turn on EIGRP on that interface. Therefore when you don’t use wildcard mask EIGRP will turn on EIGRP on all interfaces that belongs to the network you specify in the “network …” command.

You should only use wildcard mask on EIGRP if you have 2 or more interfaces that belong to the same major networks but you don’t want to run EIGRP on all of them. For example if your router has 2 interfaces whose IP addresses are 192.168.30.1/28 and 192.168.30.17/28 but you only want to run EIGRP on the first interface, you can type “network 192.168.30.0 0.0.0.15” under EIGRP process.

Comments
Comment pages
1 2 3 81 29
  1. themoiph
    December 7th, 2010

    when these networks are advertised under eigrp 212 should they have a mask after them as they are classles networks ????????

  2. 9tut
    December 7th, 2010

    EIGRP uses classless routing, which means that the subnet mask information is sent along with routing protocol updates but you don’t need to add a mask after them

  3. Anonymous
    December 10th, 2010

    how do i open the sims in packet tracer…please help

    fde

  4. Xper
    December 10th, 2010

    1) whats the purpose of writing ” R3(config-router)#no auto-summary” this command, whats the explanation of this ?
    2) Kindly write ping command on R3 to check R1?

  5. Mohamed Emad
    December 10th, 2010

    what is the explanation of the command ( R1#copy running-config startup-config ) and also the command ( R3(config-router)#no auto-summary ) plzzzzzzzzzzzzzzzzzz

  6. Anonymous
    December 11th, 2010

    no auto-summary gets rid of problems when router adds 24 bit mask by default to any address you enter in configuration. to use custom masks like /30 you need to set no auto-summary

    copy running-config startup-config – saves current configuration file

  7. Kishore
    December 11th, 2010

    hi ,

    i am going to give ccna exam on 27 of this month.

    testinside acme and labs of 9tut only , if i perepare it is sufficent to pass the exam.

    please reply ………..

  8. Kishore
    December 11th, 2010

    and also please say , where ip nos will be chainged for this questions , during exam

    i am not taking about lab, i am talking about theory questions.

  9. Xper
    December 11th, 2010

    Kindly write ping command on R3 to check R1?

  10. Anonymous
    December 11th, 2010

    no ping command is not enough !!! it will ping R1 but you need to make sure R1 show run shows eigrp 212 network 192.168.77.0

  11. tony
    December 12th, 2010

    Guys, in the real eigrp sim exam.. .there’s extra network address. i think they are 5 network it’s under router 1 something like below…. .it won’t affect the connection… but do we need to remove it there? or leave it as it is?.

    router eigrp 212
    x.x.x.x
    c.c.c.c
    z.z.z.z
    v.v.v.v
    b.b.b.b

  12. UthmanHassan
    December 12th, 2010

    @ Mohamed Emad

    You can use auto-summarization with /30 or other masks. Anonymous’ explanation of disabling auto-sum for only being able to use masks like /30 is not correct.

    Suppose you have different networks attached to a router. By default routing protocols will not send all these networks in its routing update. Instead to save bandwidth and to keep the routing table of target router smaller, all routing protocols summarize routes at major class boundaries for networks belonging to one class.

    To see examples, check the summary route questions mentioned in I guess subnetting or operations sections of 9tut.com.

    While it’s a great feature sometimes we have to turn it off with no auto-summary command to avoid problems. For example if R1 is connected to R2 on fa0/2 and to R3 on fa0/3 and you are using same class networks say 172.16.x.x on R2 and R3 with whatever masks. It is quite possible that you have an addressing scheme for which when R3 and R2 summarize the networks, the summary route is the same and they both send it to R1.

    Now R1 will see the same summary route coming on it’s 2 different interfaces and will have no way of telling that they are different routers. It might think that it’s in 1 network it has learned on different interfaces and might start to try load balancing on fa0/2 and fa0/3 connections.

    No if some traffic arrives on R1 from some R0 for a host on R2, and some traffic arrives for a host on R3, what will happen? R1 will exit half the packets from fa0/2 and half the packets from fa0/3. No single host will get the complete traffic destined to it from R0, and R2 and R3 will keep delivering the packets that match the routes while discarding the traffic that doesn’t match.

    It would be a must to issue no auto-summary command on R2 and R3 if you have same class networks on both of them.

  13. UthmanHassan
    December 12th, 2010

    @ Mohamed Emad

    My above post , Para 2: Suppose you have…

    Correction: Not all protocols auto-summarize. AS FAR AS I KNOW RIPv2 and EIGRP auto-summarize.

  14. Decher
    December 13th, 2010

    Hi guys. I am used to add the network statments for eigrp with wilcardmask also (ex: network 192.168.77.32 0.0.0.3). Is it wrong to do so at the ccna lab? will i get full points if i do the lab this way?

  15. Rob
    December 13th, 2010

    Hi all, i take the ccna exam in a few days, does anyone have the sim for this?
    rob_jones1221@hotmail.com

  16. Rob
    December 13th, 2010

    cheers people

  17. toy
    December 13th, 2010

    9tut, regarding my post.. .do you have any idea?

  18. 9tut
    December 13th, 2010

    @tony: In real life, you should remove it but in the exam just leave it as it is.

  19. Anonymous
    December 14th, 2010

    @ Decher

    Try to stick to the syntax of the command. It’s a great thing if you’ve run into the habit of using wildcard masks. It’ll do you no harm in the lab except a slight miscalculation can ruin your configuration and in exams you’ve to be very accurate the 1st time. There are already a lot of troubleshooting questions and you wont want start troubleshooting your own SIM. Would you?

    Cheers

  20. rayan
    December 14th, 2010

    hello,
    i got packt tracer sim. i tryied with eigrp. its working fine bt m unable to ping 192.0.18.4 from R3. bt abl to do from R1.
    plz reply back ..

  21. Decher
    December 14th, 2010

    Thanks a lot for the reply. I will go take my ccna exam in 16 december. I will post again to tell you what labs/theory question i had.

  22. Rob
    December 15th, 2010

    hey people, as i belive the sims will be acl 2, eigrp and vtp, can anyone confirm if this is still true?

  23. tamem
    December 16th, 2010

    HI BROTHERS PLEASE WHO CAN TELL ME THE autonomous SAME THE PROCESS ID OR NOT I AM WAITING THE ANSWER THANKS

  24. Aamir
    December 16th, 2010

    @ tamem: In exams the AS number these days is 22 and on the wrong configured router its 23 so you have to correct it.

  25. tamem
    December 16th, 2010

    thanks Aamir

  26. Peter
    December 17th, 2010

    I had my exam on the following sims from 9tut.com
    EIGRP sim the one on this page
    Access list sim similar to the one on 9tut
    swithing vtp also on 9tute

    do all this question on 9tut LAB SIM on’s and understand and analyse the question carefully

    do pass4shure about 250 questions

    You will do more than a PASS.
    I had

  27. Peter
    December 17th, 2010

    Thankyou
    for helping me pass ccna
    http://www.9tut.com

    Mery chrismas to everybody here.

  28. waqqas
    December 17th, 2010

    how to check which route to be deleted on R1 router of eigrp sim ???

  29. sello
    December 22nd, 2010

    Hi everyone,
    pls, can i get a link like 9tut,for those in juniper networks. i want to write my jncia er next week.9tut thanks for what you are doing for ccna candidates.pls,need a quick response

  30. aymen
    December 22nd, 2010

    hello
    i want to ask if i configure each part on its own pc
    ie the configuration part concerning router3 should be configured on host d
    and the one concerning router1 on host g
    thank you

  31. stylus
    December 22nd, 2010

    How about split horizen, how do we deal with it on this senerio?

  32. Anonymous
    December 23rd, 2010

    (N/W 2 INFO) R1 R2 (N/W 1 INFO)

    Stylus,

  33. Kid
    December 23rd, 2010

    (N/W 2 INFO) R1 R2 (N/W 1 INFO)

    Stylus,
    R1 and R2 will share their diractly connected n/w, But they will not revert the n/w info wher you learned. Ex. R1 will not update n/w 1 info back in to (R1 s/0) where it learned.

  34. teeka
    December 28th, 2010

    got this 2day .. with slight difference (22 , 221 ) , thxxx 9tut

  35. nym
    January 1st, 2011

    can someone please explain where we got these to addresses from:

    R3(config-router)#network 192.168.60.0
    R3(config-router)#network 192.168.77.0

    Thanks

  36. Ahmed \
    January 3rd, 2011

    @teeka, which dumps did you study and which sims were on your exam plz. Was questions the same?

    So nervous for write cisco exAM!

  37. TiredEyes
    January 4th, 2011

    9tut

    Why are there no wildcard masks after the network commands ?

    I’m confused, surely following this exact example we’ll drop marks ??

  38. 9tut
    January 5th, 2011

    We don’t need to use wildcard mask when it’s in the major network. For example the 2 commands below are the same:
    network 192.168.60.0 is same as
    network 192.168.60.0 0.0.0.255

  39. mark
    January 6th, 2011

    can anyone explain why there is the command no auto-summary on router 3 but not on router 1

  40. mark
    January 6th, 2011

    I’m about to take my exam at 3pm West African time. Please 9tut give me an answer

  41. Shamal
    January 6th, 2011

    If I do

    network 192.168.60.0 0.0.0.255
    network 192.168.77.0 0.0.0.255
    no-auto-summary

    OR

    network 192.168.0.0 0.0.255.255
    no-auto-summary

    they do the same thing. and both give the same result and routing info in R1.
    In the exam , does it matter which way I’m doing it ???
    will I get the full marks either way ??

    please reply !!

    Thanks.

  42. 9tut
    January 6th, 2011

    @mark: R1 has the “no auto-summary” command too but we don’t need to type it again because we don’t create a new AS in R1 and this command exists in the current AS. In R3, we need to create a new AS 212 to replace AS 22 so we need to add “no auto-summary” command.

    @Shamal: Both your configurations are correct in real life but in the exam you have to do on a simulator (with programmed answers) so my recommendation is “never try anything you are not sure”. Always do the sims in the best & clearest way!

  43. Shamal
    January 7th, 2011

    thanks 9tut.

  44. RAM
    January 7th, 2011

    Can anyone tell me which ip i’ve to ping from R3..aft i have done the above changes..??

  45. Tman
    January 11th, 2011

    shouldn’t the network statements be the actual subnet address? for example 192.168.77.34 255.255.255.252 should be network 192.168.77.32. Why is it 192.168.77.0 in this configuration?

  46. Tman
    January 11th, 2011

    Nevermind, it’s because of no auto-summary. I didn’t see that there…

  47. Mr.J
    January 11th, 2011

    Hi mates, i was fail yesterday only score 815 out 1000. there are many quetions’ been changed.just be carefull with simulation questions, its very hard but the multi answer question, i think its no to hard. i had only 3 sim questions, i only have 1 right but still fail. so just be carefull with sim question. im gonna reseat again in a week time. best of luck to all of u.

  48. Curios
    January 11th, 2011

    Hi guys, just finish my exam now and it was so cool, scored 949 sims are eigrp, access list, vtp but made a mistake with vtp, i only did 1 questn and click next.
    Thank God, thank u guys, thank 9tut re d best.

  49. Bouhdila
    January 12th, 2011

    @Curios
    can you please confirm that there are no change in the mashti or acme dump?
    Thx

  50. Curios
    January 12th, 2011

    @bolhdila
    yes i can assure u that i’m 90 % sure acme is still very valid.
    Just study hard nd understand d concept bcos there is no value for Certification without Knowledge.

Comment pages
1 2 3 81 29
Add a Comment