Home > CCNA EIGRP Lab

CCNA EIGRP Lab

January 25th, 2014 Go to comments

Question

Your company has just added R3 router to the existing network. But currently no routing updates are being exchanged between R3 and the network. All other connectivity, including Internet access are working properly.

The task is to identify the fault(s) and correct the router configuration to provide full connectivity between the routers.

All passwords on all routers are set to cisco.

IP addresses are listed in the chart below.

ccna_eigrp_sim

R1
Fa0/0: 192.168.77.33
S1/0: 198.0.18.6
S0/1: 192.168.60.25
S0/0: 192.168.36.13
R2
Fa0/0: 192.168.60.97
Fa0/1: 192.168.60.113
S0/0: 192.168.36.14
R3
Fa0/0: 192.168.77.34
Fa0/1: 192.168.60.65
Fa1/0: 192.168.60.81
R4
Fa0/0: 192.168.60.129
Fa0/1: 192.168.60.145
S0/1: 192.168.60.26

Answer and explanation

(Note: If you are not sure how EIGRP works, please read my EIGRP tutorial: http://www.9tut.com/eigrp-routing-protocol-tutorial. Note: You can download this sim to practice here: http://www.9tut.com/download/9tut.com_CCNA_EIGRP_sim_question.zip)

We should check the configuration of the new added router first because it does not function properly while others work well. From the command line interface of R3 router, enter the show running-config command

ccna_eigrp_sim_show_run

From the output above, we know that this router was wrongly configured with an autonomous number (AS) of 22. When the AS numbers among routers are mismatched, no adjacency is formed.

(You should check the AS numbers on other routers for sure)

To solve this problem, we simply re-configure router R3 with the following commands:

R3>enable (you have to enter Secret@9tut as its password here)

R3#configure terminal

R3(config)#no router eigrp 22

R3(config)#router eigrp 212

R3(config-router)#network 192.168.60.0

R3(config-router)#network 192.168.77.0

R3(config-router)#no auto-summary

R3(config-router)#end

R3#copy running-config startup-config

Check R1 router with the show running-config command:

ccna_eigrp_sim_show_run_2

Notice that it is missing a definition to the network R3. Therefore we have to add it so that it can recognize R3 router

R1>enable (you have to enter cisco as its password here)

R1#configure terminal

R1(config)#router eigrp 212

R1(config-router)#network 192.168.77.0

R1(config-router)#end

R1#copy running-config startup-config

Now the whole network will work well. You should check again with ping command from router R3 to other routers!

Modifications:

Maybe in this EIGRP Sim you will see the “passive-interface …” command somewhere in R1 configuration. If the link between R1 to R2; or R1 to R3; or R1 to R4) routers has the “passive interface” then we have to remove it with the “no passive-interface …” command because it prevents EIGRP update from being sent on that interface. But if the “passive interface” is applied to the link between R1 and ISP router like this:

R1:

!
router eigrp 212
passive-interface s1/0
!

then we just leave it. Don’t use the “no passive-interface s1/0” on R1 because the link between R1 & ISP doesn’t need EIGRP to run on it. A static route from R1 to ISP & “ip default-network” command in R1 are correct so that all the routers (R1, R2, R3, R4) can access the Internet.

(Note: The “ip default-network” command in R1 will advertise the static route of R1 (to go to the Internet) to other routers (R2,R3,R4) so that they can access the Internet too). In the exam you will see these lines in R1 configuration:

!
ip default-network 198.0.18.0
ip route 0.0.0.0 0.0.0.0 198.0.18.5
!

If you want to learn more about “ip default-network” command please read: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml

I read recent comments and realized that you will see the “passive-interface” in the link between R1 & ISP router so just leave it.

Note: Also some readers confuse about if we should use the wildcard masks on the “network” statements under EIGRP process or not. For example should we use:

router eigrp 212
network 192.168.77.0 0.0.0.3

The answer is: we can use wildcard masks or not, it does not matter. Not having a wildcard mask does not make the routes conflicting. The “network …” command in EIGRP (and OSPF, RIP) does not means “advertise this network” but means “If I has interface(s) belongs to this network please turn on EIGRP on that interface. Therefore when you don’t use wildcard mask EIGRP will turn on EIGRP on all interfaces that belongs to the network you specify in the “network …” command.

You should only use wildcard mask on EIGRP if you have 2 or more interfaces that belong to the same major networks but you don’t want to run EIGRP on all of them. For example if your router has 2 interfaces whose IP addresses are 192.168.30.1/28 and 192.168.30.17/28 but you only want to run EIGRP on the first interface, you can type “network 192.168.30.0 0.0.0.15” under EIGRP process.

Comments
Comment pages
1 77 78 79 80 81 29
  1. muztee
    December 15th, 2015

    @9tut
    please can you confirm what sims, simlits or labs for 200-120 ccna

    i.e acl 2 eigrp ospf please confirm what i need to know for 200-120 thank you

  2. aneeque
    December 18th, 2015

    is frame relay sim included in ccna exam or not ?

  3. Sant
    December 19th, 2015

    I have executed this lab in packet tracer with same commands as shown in the answers…. But still R3 routing table s not updated with eigrp routes and not forming adjacency with R1 .. Did someone experienced the same problem as me ..
    . or its mistake from my side… I’m damm sure I entered same commands…

  4. Clover
    December 19th, 2015

    Sant, It worked for me in packet tracer.

  5. Ahlam
    December 20th, 2015

    I have passed CCNA exam today 980/1000 thanks 9tut.com

  6. itsnotblank
    January 4th, 2016

    Dear Naeem, Thank you for the link good bless you..

  7. ghetto
    January 4th, 2016

    Ahlam tell me what came

  8. kyubi03
    January 13th, 2016

    @Sant checK R1 maybe you forgot to input R3 network on R1. NO problems if you correctly configured R1 and R3 and lastly, you should know how eigrp works for you to easily troubleshoot eigrp problems.

  9. Anonymous
    January 14th, 2016

    I passed the exam with score 922

  10. J.Amol
    January 19th, 2016

    Hey are the version 25 updated dumps? Thinking of appearing on 25th January. Guys Please post the drive link of updated dumps. Thanks

  11. Anonymous
    January 20th, 2016

    Hi guys,

    Any of you have the VCE file for 210-060 (CCNA Collaboration) ?

    Please send it to {email not allowed}

    THANK YOU very much! 9tut is the best

  12. anon
    January 22nd, 2016

    guys anyone attempted second time? if attempted are the labs same or they are different

  13. Anonymous
    January 25th, 2016

    hi

  14. Rerun73
    January 27th, 2016

    I did not see this in the above lab on R1:
    R1:
    !
    router eigrp 212
    passive-interface s1/0
    !
    Also the static route is on ISP router not on R1
    !
    ip route 0.0.0.0 0.0.0.0 198.0.18.6
    !
    My question is, should the passive-interface s1/0 command be added if it is not in R1?
    We only discuss not removing it.

  15. tryna pass
    January 28th, 2016

    Hey guys, for those who have passed What were changes in ospf troubleshooting in the exam?

  16. michella
    February 13th, 2016

    guys anyone who wrote resent. Wat r the changes to exam am scheduled to ryt on monday.
    insight appreciated

  17. msal
    February 13th, 2016

    WHAT IS PASSWORD FOR THIS LAB

  18. Dola
    February 14th, 2016

    what changes in this lab ?

  19. Dola
    February 14th, 2016

    is there any change in this lab

  20. Kush
    February 17th, 2016

    @msal its “cisco”

  21. kurdi J
    February 24th, 2016

    Please guys my exam is in two days please send me the latest lab at {email not allowed}

  22. kurdi J
    February 24th, 2016

    {email not allowed}

  23. kurdi J
    February 24th, 2016

    Here is my mail {email not allowed}

  24. luca
    March 1st, 2016

    is possible have a dumo i want do exam,,,i look in dump all answear or is possibigle have new answear?

  25. Anonymous
    March 3rd, 2016

    Is there any NAT sim’s? thx

  26. Anonymous
    March 3rd, 2016
  27. Sherry
    March 4th, 2016

    EIGRP lab :

    ping is not done. i have configure EIGRP lab as instructed.
    but i fail to ping. can any one guide ???

  28. Sherry
    March 4th, 2016

    where Static Route define ?? on R1 Or ISP ?? and write down commands also…..

  29. naveed
    March 14th, 2016

    today i passed exam nd by the grace of Allah got 980 marks…………

  30. Anonymous
    March 14th, 2016

    what were the labs in exam please tell naveed.

  31. Anonymous
    March 21st, 2016

    How many questions in CCNA exam all in all ?

  32. Babs
    March 22nd, 2016

    What Questions are very common in Objectives/multiple answers section?? taking the exam on Wednesday.

  33. D
    March 22nd, 2016

    Hi Babs , what reviewer are you taking right now ? can you tell me what are the questions you encounter after your exam ?

  34. Jmc06
    March 22nd, 2016

    Hello All,

    I have downloaded: CCNAquestions_Jul_7_2015.pdf. Is there a much updated version. I tried this one as advised by 9tut. Thanks all!

  35. 9tut
    March 22nd, 2016

    @Jmc06: You can download newest questions at http://www.9tut.com/ccna-questions-and-answers

  36. happy
    March 23rd, 2016

    Hi guys. Ellamdülillah I passed my exam today. 960/1000 — thanks guys and 9tut.

    dump =360 dumps

    -ACL2 —mod3 (only ip change)
    -ACL1 — same
    -OSPF — same
    -EİGRP troubleshooting —answer change

    EİGRP troubleshooting answer =

    Q1= The loopback addresses haven’t been advertised, and the network command is missing on R4.

    Q2= The traffic is equally load-balanced over R2 and R3.

    Q3= The K values mismatch.

    Q4= The network statement is missing on R5

    good luck guys…

  37. 19jb
    March 23rd, 2016
  38. teehee
    March 24th, 2016

    i tried this eigrp problem, when i add network 192.168.77.0 0.0.0.3 in R1 router eigrp 212, still i could confirm R3s connectivity with other routers. when i removed wildcard bits, it was ok. please teach me.

  39. teehee
    March 24th, 2016

    when i use 255.255.255.0 mask, adjacency to R3 is confirmed. why? isnt it supposed to be wildcard bits that should be used?

  40. krish
    March 26th, 2016

    can someone explain why R1 and R3 can’t be neighbors when you input
    “network 192.168.77.0 0.0.0.3” on both routers?

    i understand that typing network 192.168.77.0 alone would make them neighbors because of /24 but why cant they be neighbors with /30 (0.0.0.3)

  41. krish
    March 26th, 2016

    ohh i get it.. i think what should be written is “network 192.168.77.32 0.0.0.3” for them to be neighbors. Am i right? can someone assess? because i tried typing “network 192.168.77.0 0.0.0.3” on both routers and the adjacency was lost.

  42. DK
    April 1st, 2016

    Yeah, there wasn’t a subnet for 192.168.77.0, so no interfaces to advertise for it. The mask was /30 for all the interfaces, .34, .65, and .81. So, knowing /30 networks are multiples of 4, round .34 down to .32, .65 down to 64, and .81 down to 80 for your network addresses. If /30 were applied to 192.168.77.0, you’d be advertising for interfaces in the range of 192.168.77.1 – 192.168.77.2.

  43. Huseyin
    April 11th, 2016
  44. Andy
    April 12th, 2016

    Can any one plz send latest dumps I m taking exam on this monday. Email id: anirudh dot upakari14 at gmail.com

  45. love leo
    April 29th, 2016

    @9tut or @anybody !!!
    I have a question regarding last paragraph of the above tutorial, In which you said that If we have two interfaces of a Router and we want to run EIGRP on first interface then we should use the command :
    network 192.168.30.0 0.0.0.15
    under EIGRP process,
    My question is , If we want to run EIGRP on SECOND Interface of the router then what command we should use, your help will be highly appreciated, thanks in advance.

  46. ammar
    April 30th, 2016

    alhamdulillah WE PASSED TODAY ME 980 MY FRIEND GOT 1000/1000 DUMPS 100% VALID WATSON AND KNORD
    Labs:
    ACL2 —Modification 3
    ACL1 — same
    OSPF — same
    EİGRP troubleshooting answer:
    Q1= The loopback addresses haven’t been advertised, and the network command is missing on R4.
    Q2= The traffic is equally load-balanced over R2 and R3.
    Q3= The K values mismatch.
    Q4= The network statement is missing on R5
    THANKS TO UMAR ,linkent AND MIDHUN
    IF YOU WANT DUMPS EMAIL ME AMMAR.MO2013 @ GMAIL .COM

  47. uni
    May 3rd, 2016

    for those who took the recent ccna exams, are watson and knord still valid? can you share the knord dumps? thanks!

  48. Anonymous
    May 3rd, 2016

    Guys can someone plz send me the latest pdf file ?
    {email not allowed}

  49. FarhanAli
    May 3rd, 2016

    @uni @ anonymous guys , i have blog, recently uploaded there dumps, go get it w w w. technologyehow . b log sp ot. co m

  50. foxer77
    May 4th, 2016

    ammar please send dump?TY
    piadinaro77 @ yahoo .it

Comment pages
1 77 78 79 80 81 29
Add a Comment