Home > Switch Questions

Switch Questions

February 6th, 2017 Go to comments

Question 1

Explanation

In cut-through switching, the switch copies into its memory only the destination MAC address (first six bytes of the frame) of the frame. After processing these first six bytes, the switch had enough information to make a forwarding decision and move the frame to the appropriate switchport. This switching method is faster than store-and-forward switching method.

In store-and-forward switching, the switch copies each complete Ethernet frame into the switch memory and computes a Cyclic Redundancy Check (CRC) for errors. If a CRC error is found, the Ethernet frame is dropped. If no CRC error is found then that frame is forwarded.

Question 2

Explanation

From the output we notice that the administrator has just shut down Interface Vlan1, which is the default VLAN so no one can access it remotely (like telnet) -> B is correct.

Answer A is not correct as STP calculation does not depend on which port comes up first or last. STP recalculates when there is a change in the network.

A normal switch can operate without VLAN -> C is not correct.

This IOS does support VLAN because it has VLAN 1 on it -> D is not correct.

Question 3

Explanation

Host A (172.19.1.1) and the management IP address of the Switch (172.19.1.250) are in the same subnet so telnet from host A to the switch can be successful even if a default gateway is not set on host A.

But host B (172.19.32.2) and the management IP address of the Switch (172.19.1.250) are not in the same subnet so host B needs a default gateway to telnet to the switch. The default gateway on host B should be 172.19.32.254.

Question 4

Question 5

Question 6

Explanation

In the configuration above, the “no shutdown” command was missing so interface Vlan 1 is still inactive. Notice that only the loopback command does not need the “no shutdown” command to work.

Question 7

Explanation

A VLAN does not need to be assigned to any port -> B is not correct.

An access port can only receive traffic from one VLAN -> C is not correct.

If not assigned to a specific VLAN, an access port carries traffic for VLAN 1 by default -> D is not correct.

An access port will drop packets with 802.1Q tags -> A is correct. Notice that 802.1Q tags are used to packets moving on trunk links.

Question 8

Explanation

Carrier Sense Multiple Access with Collision Detection (CSMA/CD) is the LAN access method used in Ethernet. When a device wants to gain access to the network, it checks to see if the network is free. If the network is not free, the device waits a random amount of time before retrying. If the network is free and two devices access the line at exactly the same time, their signals collide. When the collision is detected, they both back off and wait a random amount of time before retrying.

CSMA/CD is used with devices operating in half-duplex mode only. CSMA/CD helps devices connecting to half-duplex switch ports operate correctly.

Question 9

Explanation

The “!” is a special character which is not allowed in the hostname of Cisco device.

Question 10

Question 11

Explanation

All ports on a Layer 2 switch are in the same broadcast domain. Only router ports separate broadcast domains.

Question 12

Explanation

When you connect an IP phone to a switch using a trunk link, it can cause high CPU utilization in the switches. As all the VLANs for a particular interface are trunked to the phone, it increases the number of STP instances the switch has to manage. This increases the CPU utilization. Trunking also causes unnecessary broadcast / multicast / unknown unicast traffic to hit the phone link.

In order to avoid this, remove the trunk configuration and keep the voice and access VLAN configured along with Quality of Service (QoS). Technically, it is still a trunk, but it is called a Multi-VLAN Access Port (MVAP). Because voice and data traffic can travel through the same port, you should specify a different VLAN for each type of traffic. You can configure a switch port to forward voice and data traffic on different VLANs. Configure IP phone ports with a voice VLAN configuration. This configuration creates a pseudo trunk, but does not require you to manually prune the unnecessary VLANs.

The voice VLAN feature enables access ports to carry IP voice traffic from an IP phone. You can configure a voice VLAN with the “switchport voice vlan …” command under interface mode. The full configuration is shown below:

Switch(config)#interface fastethernet0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#switchport voice vlan 20

Reference: http://www.cisco.com/c/en/us/support/docs/switches/catalyst-4500-series-switches/69632-configuring-cat-ip-phone.html

Question 13

Explanation

To remote access to SwitchB, it must have a management IP address on a VLAN on that switch. Traditionally, we often use VLAN 1 as the management VLAN (but in fact it is not secure).

In the exhibit, we can recognize that the Management Workstation is in a different subnet from the SwitchB. For intersubnetwork communication to occur, you must configure at least one default gateway. This default gateway is used to forward traffic originating from the switch only, not to forward traffic sent by devices connected to the switch.

Question 14

Explanation

Microsegmentation is a network design (functionality) where each workstation or device on a network gets its own dedicated segment (collision domain) to the switch. Each network device gets the full bandwidth of the segment and does not have to share the segment with other devices. Microsegmentation reduces and can even eliminate collisions because each segment is its own collision domain -> A is correct.

Note: Microsegmentation decreases the number of collisions but it increases the number of collision domains.

D and E are correct based on the theory of STP and VLAN.

Question 15

Question 16

Explanation

The MAC address of 00b0.d056.efa4 has not been learned in its MAC address table so Switch-1 will broadcast the frame out all of its ports except the port from which the data originated.

Comments (1) Comments
  1. Manan
    February 23rd, 2017

    question no 13:

    B.
    SwitchB(config)#ip default-gateway 192.168.8.254
    SwitchB(config)#interface vlan 1
    SwitchB(config-if)#ip address 192.168.8.252 255.255.255.0
    SwitchB(config-if)#no shutdown

    D.
    SwitchB(config)#ip default-network 192.168.8.254
    SwitchB(config)#interface vlan 1
    SwitchB(config-if)#ip address 192.168.8.252 255.255.255.0
    SwitchB(config-if)#no shutdown
     
    I do not find out any different between B & D. But answer is B . Could you explain ?