Home > EIGRP Questions

EIGRP Questions

November 3rd, 2018 Go to comments

Note: If you are not sure about EIGRP, please read our EIGRP Tutorial.

Question 1

Explanation

Below is an example of the “show ip eigrp neighbors” output.

EIGRP_show_ip_eigrp_neighbors_2.jpg

Let’s analyze these columns:

+ H: lists the neighbors in the order this router was learned
+ Address: the IP address of the neighbors
+ Interface: the interface of the local router on which this Hello packet was received
+ Hold (sec): the amount of time left before neighbor is considered in “down” status
+ Uptime: amount of time since the adjacency was established
+ SRTT (Smooth Round Trip Timer): the average time in milliseconds between the transmission of a packet to a neighbor and the receipt of an acknowledgement.
+ RTO (Retransmission Timeout): if a multicast has failed, then a unicast is sent to that particular router, the RTO is the time in milliseconds that the router waits for an acknowledgement of that unicast.
+ Queue count (Q Cnt): shows the number of queued EIGRP packets. It is usually 0.
+ Sequence Number (Seq Num): the sequence number of the last update EIGRP packet received. Each update message is given a sequence number, and the received ACK should have the same sequence number. The next update message to that neighbor will use Seq Num + 1.

In this question we have to check the RTO and Q cnt fields.

Question 2

Explanation

To configure EIGRP for IPv6 we must explicitly specify a router ID before it can start running. For example:

ipv6 router eigrp 1
eigrp router-id 2.2.2.2
no shutdown

Notice that EIGRP for IPv6 router-id must be an IPv4 address. EIGRP for IPv4 can automatically pick-up an IPv4 to use as its EIGRP router-id with this rule:
+ The highest IP address assigned to a loopback interface is selected as the router ID.
+ If there are not any loopback addresses configured, the highest IP address assigned to any other active interface is chosen as the router ID

EIGRPv3 also uses the AS number (for example: ipv6 eigrp 1 under interface mode).

Question 3

Explanation

The “show ipv6 eigrp neighbors” command displays the neighbors discovered by the EIGRPv6. Notice that the neighbors are displayed by their link-local addresses.

show_ipv6_eigrp_neighbors.jpg

Question 4

Explanation

The goodbye message is a feature designed to improve EIGRP network convergence. The goodbye message is broadcast when an EIGRP routing process is shutdown to inform adjacent peers about the impending topology change. This feature allows supporting EIGRP peers to synchronize and recalculate neighbor relationships more efficiently than would occur if the peers discovered the topology change after the hold timer expired.

The following message is displayed by routers that run a supported release when a goodbye message is received:

*Apr 26 13:48:42.523: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.1 (Ethernet0/0) is down: Interface Goodbye received

Reference: http://www.cisco.com/c/en/us/td/docs/ios/12_2/ip/configuration/guide/fipr_c/1cfeigrp.html

Note: In this question we should understand “impending”, not “implementing” as there are no correct answers with “implementing” topology change.

Question 5

Explanation

With auto-summary feature is turned on, EIGRP will summary these networks to their classful networks automatically. For example:
+ 172.15.4.0 belongs to class B so it will be summarized to 172.15.0.0
+ 10.4.3.0 belongs to class A so it will be summarized to 10.0.0.0
+ 192.168.4.0 belongs to class C so it will be summarized to 192.168.4.0 (same)

Question 6

Explanation

Split horizon is used in distance vector routing protocols (like RIP, EIGRP) to prevent routing loops by prohibiting a router from advertising a route back to the interface from which it was learned.

Question 7

Explanation

EIGRP provides a mechanism to load balance over unequal cost paths (or called unequal cost load balancing) through the “variance” command. In other words, EIGRP will install all paths with metric < variance * best_metric into the local routing table, provided that it meets the feasibility condition (to prevent routing loop). The feasibility condition states that, the Advertised Distance (AD) of a route must be lower than the feasible distance of the current successor route.

Question 8

Explanation

EIGRP provides a mechanism to load balance over unequal cost paths (or called unequal cost load balancing) through the “variance” command. In other words, EIGRP will install all paths with metric < variance * best_metric into the local routing table, provided that it meets the feasibility condition (to prevent routing loop). The feasibility condition states that, the Advertised Distance (AD) of a route must be lower than the feasible distance of the current successor route.

Question 9

Explanation

From the routing table we learn that network 192.168.10.0/30 is learned via 2 equal-cost paths (192.168.10.9 &192.168.10.5) -> traffic to this network will be load-balancing.

Question 10

Explanation

This is an example of how to configure EIGRP for IPv6:

interface Serial0/0
no ip address
ipv6 address FE80::1 link-local
ipv6 address 2010:AB8::1/64
ipv6 enable
ipv6 eigrp 1
!
ipv6 router eigrp 1
eigrp router-id 2.2.2.2
no shutdown

As you can see, EIGRP for IPv6 can only be enabled under each interface -> A is correct.

Under EIGRP process there is a shutdown feature where you can turn on or off -> E is correct.

Question 11

Explanation

These networks will be summarized to the major networks of that class so:
+ 10.4.3.0 belongs to class A -> It will be summarized into 10.0.0.0
+ 172.16.4.0 belongs to class B -> It will be summarized into 172.16.0.0
+ 192.168.2.0 belongs to class C -> It will be summarized into 192.168.2.0 (not changed)

Question 12

Question 13

Question 14

Explanation

The command “ipv6 summary-address eigrp as-numberipv6-address [admin-distance]” can be used to configure a summary aggregate address for a specified interface. We can also configure the administrative distance of that summary aggregate address as well.

Note: The “ipv6 bandwidth-percent eigrp” command configures the percentage of bandwidth that may be used by EIGRP for IPv6 on an interface. By default, EIGRP packets consume a maximum of 50 percent of the link bandwidth.

EIGRP for IPv6 uses the minimum bandwidth on the path to a destination network and the total delay to compute routing metrics. You can use the metric weights command to adjust the default behavior of EIGRP for IPv6 routing and metric computations.

Reference: https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_eigrp/configuration/xe-3s/ire-xe-3s-book/ip6-route-eigrp-xe.pdf

Comments (13) Comments
Comment pages
1 2 2937
  1. Anonymous
    August 13th, 2018

    gj

  2. Anonymous
    September 23rd, 2018

    is this question, “Question 5

    What are the address that will show at the “show ip route” if we configure the above statements? (Choose three)
    router eigrp 100
    network 172.15.4.0
    network 10.4.3.0
    network 192.168.4.0
    auto-summary

    A. 10.0.0.0
    B. 10.4.3.0
    C. 172.15.4.0
    D. 172.15.0.0
    E. 192.168.4.0
    F. 192.168.0.0

    ” because if the summarization is activated the subnets will be dismantled as follows:
    192.168.4.0,
    The correct thing is not that they are: 192.168.0.0. Since the summarization is active

  3. Djoko
    November 14th, 2018

    his page. Please share the link to questions.

  4. Djoko
    November 14th, 2018

    Only answers are displayed. Please share the link to questions.

  5. cris
    December 2nd, 2018

    Can someone explain the question 13 is C?
    I think we need first create a process ID, once it is created the system will take the router id from highest loopback ip address or highest ipv4 interface, if not available we need put it manually. I think the answer should be D, but if there is not I assume answer is C because we already create the process id and now need put the router id because there is not loopback or interface configured. The question need to be more clear.

  6. required cisco 200-125 dumps
    February 20th, 2019

    required cisco 200-125 dumps at rupanineel26 at gmail dot com,
    please send

  7. need ccna 200-125 dumps
    April 3rd, 2019

    axelwess at gmail dot com

  8. bill
    April 30th, 2019

    had exam yesterday. Question 9 came up. exactly same answer:

    Refer to the exhibit. Based on the exhibited routing table, how will packets from a host within the 192.168.10.192/26 LAN be forwarded to 192.168.10.1?

    A. The router will forward packets from R3 to R2 to R1
    B. The router will forward packets from R3 to R1
    C. The router will forward packets from R3 to R1 to R2
    D. The router will forward packets from R3 to R2 to R1 AND from R3 to R1

    Answer: D

  9. IDK
    April 30th, 2019

    @bill
    thank you!
    what other questions do you remember? are the sims still valid?

  10. bill
    May 2nd, 2019

    @IDK. there was nice and easy questions too, like what is internal admin distance for EIGRP :)

    trunking questions, like what happens if both ends of link are set to dynamic auto?

    what will stop a pc from receiving IP address from DHCP server ?
    -STP
    -VTP
    -DTP
    -802.1Q.

    I guessed 8021q

    i just had GRE Multi link sim and EIGRP troubleshooting. same questions, but answers/configurations bit different.

  11. Anonymous
    June 3rd, 2019

    @Cris check this:

    The router ID needs to be configured for an EIGRPv6 protocol instance before it can run

    https://www.cisco.com/c/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/113267-eigrp-ipv6-00.html
    Answer is: C, Router ID.

  12. mister
    June 3rd, 2019

    @bill Hi!
    On your exam did you get any SDN or SNMP question? Thanks

  13. Mahbuub
    November 16th, 2019

    how abt Q4 is it correct “implementing” answer C
    OR just for “impending ” should be answer C

Comment pages
1 2 2937
Add a Comment